Cloud is trying to perform a factory-update on previously updated photons
Incident Report for Particle
Postmortem

As we've been adding support for product creators, we added a new system to let product creators manage their firmware updates with their products. While this new system works very well, updates for the photon were incorporated under this new umbrella.

When a new photon factory update was released, it was given a new (correct) version number, but this new system attempted to apply that factory update to any photons running an older version. Since that factory update can only be applied once, those photons rejected the new update, and stayed in an "waiting for update" mode until restarted.

We've fixed the configuration issue that caused this problem, and we're working on a system to avoid this in the future. Thanks for reading!

-David

Posted Jul 20, 2015 - 14:06 PDT

Resolved
We've fixed the configuration issue that caused this problem, and we're working on making sure this doesn't happen again.
Posted Jul 20, 2015 - 13:48 PDT
Identified
We've identified this issue and are working on a fix.
Posted Jul 20, 2015 - 13:33 PDT