Devices unable to connect to cloud
Incident Report for Particle
Postmortem

One of our third-party storage providers performed maintenance today, and Particle's systems were fully available during that window. However, when they brought the server back up, they did so partially, in an unexpected way that caused device connections to fail for 17 minutes from 9:51am to 10:08am PST.

In 3 days on Nov 29 this partner will perform similar maintenance on another server, and Particle will prepare our systems to handle the same kind of failure without customer impact.

Additionally, recent improvements in cloud metrics provided an opportunity to respond even more quickly in similar future scenarios. We created a new alert to make use of this new data.

Posted 16 days ago. Nov 26, 2018 - 12:04 PST

Resolved
This incident has been resolved.
Posted 16 days ago. Nov 26, 2018 - 10:41 PST
Update
We are continuing to monitor for any further issues.
Posted 16 days ago. Nov 26, 2018 - 10:32 PST
Monitoring
The issue has been identified and devices are beginning to reconnect. We are monitoring the situation.
Posted 16 days ago. Nov 26, 2018 - 10:13 PST
Investigating
We are currently seeing issues with devices connecting with the cloud.
Posted 16 days ago. Nov 26, 2018 - 10:00 PST
This incident affected: Device Service.