Some customers getting lots of duplicate emails
Incident Report for Particle
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 15, 2019 - 10:08 PST
Monitoring
We've identified the issue and have put some temporary measures in place to reduce the # of duplicate emails. We're working on a more permanent solution and we'll roll it out tomorrow without disruption.
Posted 4 months ago. Feb 11, 2019 - 18:22 PST
Investigating
We've been hearing from a few of our users that they're getting lots and lots of duplicate emails. Our email provider had some downtime last week, and it appears that as they're working through their backlog, they're sending out multiple emails for every one we send them.

We're investigating the issue on our side and working with the provider as well. We hope to have this resolved by the end of the day today. We know you like to hear from us, but hearing 3,000 times from us in a day is pretty annoying. :)

This issue doesn't affect many people, but it's a serious problem for the people who are affected. We're sorry about that and are working quickly to resolve it for you.
Posted 4 months ago. Feb 11, 2019 - 12:26 PST