Connectivity Incident
Incident Report for Particle
Resolved
Rogers has reported that this incident is within the final resolution phase. Traffic has returned to previously established levels and stabilized, so we are marking this incident as resolved from our perspective. Should any changes occur, we will reopen this incident.
Posted Jul 10, 2022 - 14:48 PDT
Update
Metrics for devices connected via Rogers have been steadily improving. We will keep this status page up as Rogers has not yet signaled that the issue is resolved, and will circle back if anything changes from our perspective.
Posted Jul 08, 2022 - 16:33 PDT
Monitoring
Particle has observed a marked improvement in Rogers' Wi-Fi services over the past 90 minutes. Cellular services also are recovering slowly.
Posted Jul 08, 2022 - 13:31 PDT
Update
Particle has observed another degradation in cellular performance, returning to original levels of impact. WiFi continues to be as affected as before.

The outage is well-publicized, affecting the Rogers network in Canada. There is no currently-offered ETA for resolution, though we will continue to provide realtime updates based on insights from our fleet.
Posted Jul 08, 2022 - 10:01 PDT
Update
Particle has observed some marginal improvement on Cellular connectivity for the provider affected by this outage, but no change yet in Wifi connectivity. We will continue to post updates as we monitor the affected components of our fleet.
Posted Jul 08, 2022 - 07:42 PDT
Update
We are continuing to monitor this outage, scoped to a specific ISP and Cellular provider in Canada. As it stands, there is little definitive sign of recovery as of yet. We will provide updates as soon as we see indications on our end that the situation is improving.
Posted Jul 08, 2022 - 05:15 PDT
Identified
We have identified that the connectivity incident is isolated to devices on particular Internet and Cellular networks in Canada. We will provide updates accordingly.
Posted Jul 08, 2022 - 04:08 PDT
Investigating
We are currently investigating a connectivity incident affecting a subset of devices. We will provide more information shortly.
Posted Jul 08, 2022 - 03:28 PDT
This incident affected: Cellular Connectivity and Wi-Fi Connectivity.