Electron 2G/3G (Non EtherSIM, non LTE) connectivity disruption

Incident Report for Particle

Resolved

Particle has confirmed that devices have recovered and are operating as expected.
Posted Apr 29, 2025 - 07:48 PDT

Update

We are observing signs of recovery, with fleet connectivity numbers gradually increasing. The trend is positive and noticeable. We will continue monitoring closely until full resolution.
Posted Apr 28, 2025 - 16:34 PDT

Monitoring

Electron/E-series devices on 2G/3G in North America, and around the world (non-EtherSIM), are currently affected by the power outages in Spain. Our cellular partner is affected and devices will be offline until power is restored in the region.
Particle will provide updates as more information becomes available.
Posted Apr 28, 2025 - 11:32 PDT
This incident affected: Cellular Connectivity.