Cellular Connectivity Incident
Incident Report for Particle
Resolved
This incident has been resolved.
Posted Mar 24, 2022 - 18:53 PDT
Monitoring
We have observed a strong recovery. The vast majority of impact affected non-EtherSIM cellular devices in Africa, though some devices in Europe were impacted as well.
Posted Mar 24, 2022 - 17:36 PDT
Update
We have identified this incident as regionally confined to a subset of devices outside of North America and Asia. Signs point to a cellular networking infrastructure issue.
Posted Mar 24, 2022 - 17:14 PDT
Investigating
We are investigating a connectivity alert. We will provide more details as soon as possible.
Posted Mar 24, 2022 - 16:57 PDT
This incident affected: Cellular Connectivity.