SIM activation delays

Incident Report for Particle

Resolved

This incident has been resolved.
Posted Jan 06, 2026 - 11:00 PST

Identified

Particle is aware that some SIM activations are currently facing extended delays. Our cellular partners are actively working on a fix.
Posted Jan 06, 2026 - 07:53 PST
This incident affected: Telephony Providers (SIM state management).