EtherSIM outage in USA and Canada

Incident Report for Particle

Resolved

The incident has resolved and devices are connecting as expected.
Posted Jun 04, 2025 - 04:24 PDT

Identified

The problem has been identified, we are seeing a recovery in the number of devices online.
Posted Jun 04, 2025 - 01:31 PDT

Investigating

EtherSIM devices in Canada and the US have experienced connectivity issues. Particle team is investigation
Posted Jun 04, 2025 - 01:09 PDT
This incident affected: Cellular Connectivity and Telephony Providers (Ether SIM).