Ethersim connection instability

Incident Report for Particle

Resolved

Connectivity has recovered.
Posted May 01, 2026 - 14:01 PDT

Monitoring

Our partners have identified the cause of the disruptions, and are observing recovery. We'll continue to monitor the situation.
Posted May 01, 2026 - 12:34 PDT

Investigating

Particle is investigating reports of EtherSIM connection instability.
Posted May 01, 2026 - 11:16 PDT
This incident affected: Cellular Connectivity and Telephony Providers (Ether SIM).