Degraded Performance in SIM Management

Incident Report for Particle

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 13:48 PDT

Monitoring

The performance of SIM card state changes has improved, and the system is now processing requests as expected. Our monitoring shows that operations such as activation and deactivation are functioning normally. We will continue to closely monitor the situation to ensure stability.
Posted Jul 08, 2025 - 11:00 PDT

Investigating

We are currently experiencing delays in processing SIM card state changes (activation, deactivation). This may result in slower-than-usual performance when managing SIM states via the Particle Console or API.

Our engineering team is actively investigating the root cause and working to resolve the issue as quickly as possible. We will provide updates as more information becomes available.
Posted Jul 08, 2025 - 09:58 PDT
This incident affected: Telephony Providers (SIM state management).