Firefox doesn't trust Comodo's CA cert for some reason
Incident Report for Particle
Resolved
Fully functional certificate has been deployed to api.spark.io and community.spark.io.
Posted Apr 21, 2014 - 22:13 PDT
Update
Another cause of the issue has been identified beyond Comodo's ECC chain not being deployed to some browsers. Spark used an ECDSA key to generate the April 10 certificate that was quickly rolled back due to incompatibility with many users' browsers. Thereafter, we've gone back to using RSA 2048 keys, however Comodo's systems have continued to generate certificates using the ECC chain. As soon as Comodo issues Spark a functional certificate, we will install it.
Posted Apr 21, 2014 - 15:46 PDT
Update
Comodo says "there may be a problem with Firefox and our EC certificates". They are investigating the issue.
Posted Apr 21, 2014 - 07:04 PDT
Update
We've submitted a support ticket to Comodo and are awaiting their response.
Posted Apr 19, 2014 - 13:03 PDT
Identified
We've identified an issue with some versions of Firefox that don't appear to trust COMODO's ECC root certificate authority, trying to identify a fix for this issue.
Posted Apr 19, 2014 - 09:05 PDT