Device connectivity instability

Incident Report for Particle

Resolved

The incident has been resolved.
Posted Oct 21, 2025 - 03:51 PDT

Monitoring

We identified that our cloud services were impacted by the ongoing AWS outage.

Our team has applied some changes that allows the cloud services to auto recover when needed. Periodic disruptions are still expected, but the data to/from the cloud should improve.
Posted Oct 20, 2025 - 15:08 PDT

Update

The issue is ongoing, and the team is still investigating.
Posted Oct 20, 2025 - 14:00 PDT

Investigating

Particle is investigating issues with device connectivity to the Particle cloud.
This affects all devices, both WiFi and Cellular.
The cause is still under investigation.
Posted Oct 20, 2025 - 12:47 PDT
This incident affected: Cellular Connectivity and Wi-Fi Connectivity.