Events System Issue
Incident Report for Particle
Resolved
All systems continue to be fully operational and this issue is marked closed. To review: Particle experienced a brief outage in its event system during a routine maintenance operation. At times within this window, a number of events (e.g. publishes) did not move through our system. The issue was identified and rectified with the highest priority. Additional redundancies and safety checks will be produced to prevent future occurrences of this issue.
Posted Jul 31, 2024 - 12:18 PDT
Update
Systems are fully operational; we are continuing to monitor this full recovery very closely.
Posted Jul 31, 2024 - 11:49 PDT
Monitoring
We are monitoring a recovery; we expect a resolution timeline of a few minutes.
Posted Jul 31, 2024 - 11:45 PDT
Identified
We have identified the issue and are urgently working to deploy a change.
Posted Jul 31, 2024 - 11:42 PDT
Investigating
Particle has identified a major drop in events moving through our system. This issue is under the highest priority of escalation.
Posted Jul 31, 2024 - 11:36 PDT
This incident affected: REST API and Integrations.