O2 Issues in the UK

Incident Report for Particle

Resolved

Recovery is almost complete at this time, will reopen this incident if we see further instability in the region.
Posted May 01, 2024 - 10:22 PDT

Monitoring

We've identified a cellular outage in the UK affecting devices connected via O2 without available failover. There is no status page up yet by the provider, but data on the ground points to an issue that is in a gradual state of recovery, beginning about 9:40AM PDT. We are closely tracking the recovery and will post an update shortly.
Posted May 01, 2024 - 09:57 PDT
This incident affected: Cellular Connectivity.