EtherSIM - Service degradation

Incident Report for Particle

Resolved

The issue was resolved
Posted Mar 10, 2026 - 14:18 PDT

Investigating

We are aware of a signaling issue impacting 4G data sessions for a small percentage of devices. We are closely monitoring the issue and working with our provider to resolve it.
Posted Mar 10, 2026 - 10:00 PDT
This incident affected: Cellular Connectivity.