Canada Rogers incident

Incident Report for Particle

Resolved

Fleet connectivity levels have returned to values consistent with those before the incident. The issue appears to be resolved at this time.
Posted Jun 23, 2025 - 16:06 PDT

Monitoring

We’re seeing positive signs of recovery across the fleet. We'll continue to monitor closely over the next few hours until full restoration is achieved.
Posted Jun 23, 2025 - 14:39 PDT

Identified

All signs point to an issue isolated to the Rogers network, with devices capable of connecting to other carriers unaffected. The Particle infrastructure is operating as expected.
Posted Jun 23, 2025 - 14:07 PDT

Investigating

Particle is investigating reports of devices going offline in Canada. More information to follow.
Posted Jun 23, 2025 - 13:44 PDT
This incident affected: Cellular Connectivity.