Cellular service disruption in GB, DE, FR [Ether SIM]

Incident Report for Particle

Resolved

This incident has been resolved.
Posted May 23, 2024 - 16:18 PDT

Monitoring

The cellular disruption is over and we are monitoring the recovery.
Posted May 23, 2024 - 15:36 PDT

Investigating

We are currently experiencing partial cellular disruption in GB, FR, DE. We are investigating the issue to determine the root cause. Some other countries in Europe may experience degraded performance.
Posted May 23, 2024 - 15:01 PDT
This incident affected: Cellular Connectivity and Telephony Providers (Ether SIM).