The provider solved the issue, and the fleet recovered to values similar to before the outage
Posted Aug 18, 2025 - 03:24 PDT
Monitoring
A big part of the impacted devices has recovered by now. We will continue monitoring until full recovery is confirmed.
Posted Aug 18, 2025 - 02:16 PDT
Identified
Data sessions continue to recover gradually. Our provider is working with their downstream partner to minimize impact and restore service as quickly as possible. We continue to monitor the issue closely.
Posted Aug 18, 2025 - 01:28 PDT
Update
Our provider is continuing to investigate the issue with their downstream partner. In the meantime, we observe a gradual recovery as devices reattach using alternate routes. We continue to monitor the situation closely.
Posted Aug 18, 2025 - 00:24 PDT
Investigating
We have detected a degradation affecting Ethersim connectivity. The impact is most notable in the USA, but effects have also been observed in other regions worldwide. Our provider is currently investigating the issue.
Posted Aug 17, 2025 - 23:48 PDT
This incident affected: Cellular Connectivity and Telephony Providers (Ether SIM).