The vast majority of devices recovered around 10:00PM PDT, and we've seen two hours since of stable behavior. However, a small subset of impacted EtherSIM devices continue to struggle to connect.
Posted Mar 31, 2025 - 00:13 PDT
Update
We are continuing to monitor the recovery process, which continues to be very slow. About 35% of impacted devices have recovered.
Posted Mar 30, 2025 - 20:01 PDT
Update
The recovery process has slowed, but our network partners assure us that all resources are being directed to accelerating the recovery process. We are continuing to escalate.
Posted Mar 30, 2025 - 18:57 PDT
Update
We are monitoring a moderately paced but active recovery.
Posted Mar 30, 2025 - 17:50 PDT
Identified
Particle has identified the issue as a network provider issue and escalated with maximum veracity. We are starting to see some signs of recovery, but this is a preliminary judgment.
Posted Mar 30, 2025 - 17:39 PDT
Update
Particle is closely monitoring a major network outage impacting EtherSIM devices and are treating this incident with the highest priority. Please stand by for updates.
Posted Mar 30, 2025 - 17:27 PDT
Investigating
Particle is investigating a drop in EtherSIM device connectivity. More details to follow.