Brief API degredation
Incident Report for Particle
Resolved
The Particle API has been stable overnight so this incident is resolved. We identified the root cause as a database timeout at our 3rd party database provider. We are looking at ways to allow the Particle API to be resilient against this type of failure in the future.
Posted about 1 month ago. May 24, 2019 - 09:33 PDT
Monitoring
We were alerted at 7:44pm Pacific that the API was in a degraded state. Our on-call engineer investigated the issue and quickly restarted the API service. Within moments it started to heal and was successfully responding. It was in a degraded state for 14 minutes.

It's behaving properly now, but we'll continue to monitor it closely as we research to better understand the cause.
Posted about 1 month ago. May 23, 2019 - 20:12 PDT
This incident affected: build.particle.io, console.particle.io, api.particle.io, and login.particle.io.